Success - DX9, UPnP, & MSN Gaming Zone

N8

Success - DX9, UPnP, & MSN Gaming Zone

Post by N8 »

I just wanted to report that I've successfully tested 2 PC's running Windows XP Pro & DirectX v9.0 behind a D-Link DI-604 router in the Zone. The game used for testing was Monster Truck Madness 2 & NO port forwarding nor DXport was used. Both UPnP & "Gaming Mode" were enabled in the router admin & the firmware is the latest from D-Link's site. Both PC's can launch or join, & even play in the same game. Launching does take about 2 secs now as opposed to the .5secs it took the 1 to launch w/ port forwarding...this is the only side effect I've seen so far. I have some other games I can test & I will report back w/ any more success or any failure should it occur.
N8.
Mike

more detail

Post by Mike »

Hi, congratulations, could you give some more details though?

-were you able to host at the zone when both computers were in the same game?

-were you able to play at the zone w/ both computers in the same game with other computers from the zone not on your router?

-how about hosting with one router computer with the other one also in the game and other players from the zone?
N8

Re: more detail

Post by N8 »

Mike wrote:Hi, congratulations, could you give some more details though?

-were you able to host at the zone when both computers were in the same game?

-were you able to play at the zone w/ both computers in the same game with other computers from the zone not on your router?

-how about hosting with one router computer with the other one also in the game and other players from the zone?
Hello,

I have not found a case in which it did not work. I have 3 PC's on this network & any of them can host, any can join ,and this is all while other zoners are or aren't in the games. Its pretty neat. The only thing I have yet to test is other games, I will do this ASAP,

N8.
krakers
Posts: 1
Joined: Tue Mar 25, 2003 6:28 pm

Post by krakers »

I too would be interested in knowing what settings you used to configure the router specifially what ports or settings in either virtual server or applications. I also have the same router and am using the current firmware. I have two computers sharing one cable connection and have file/sharing and internet sharing setup via the router. One is using xp pro, the other is 98se. So far i have not been able to play any games via lan nor internet with both pc's simultaniously, specifically motocross madness 2 which im currently working on.

I found a nice webpage that allows you to virtualy view different router setups and configuration of the software.

http://www.simulationsupportpage.com/ro ... omewiz.htm

Thanks for any information you can give. ALso i want to say thanks for the Dxport program and setting up this forum. :D
N8

Post by N8 »

krakers wrote:I too would be interested in knowing what settings you used to configure the router specifially what ports or settings in either virtual server or applications. I also have the same router and am using the current firmware. I have two computers sharing one cable connection and have file/sharing and internet sharing setup via the router. One is using xp pro, the other is 98se. So far i have not been able to play any games via lan nor internet with both pc's simultaniously, specifically motocross madness 2 which im currently working on.

I found a nice webpage that allows you to virtualy view different router setups and configuration of the software.

http://www.simulationsupportpage.com/ro ... omewiz.htm

Thanks for any information you can give. ALso i want to say thanks for the Dxport program and setting up this forum. :D
I do nothing in the router config aside from enabling UPnP(I also leave "gaming mode" enabled as it is defaultly tho I have no idea what that means/does). I use no port forwarding with this setup...UPnP & DX9 do all the work for me. I will try to install MCM2 tonight or soon & test that it works as well as MTM2. A friend has a Linksys that claims to support UPnP as well & he can not get it to work. I'm guessing the key here might be the D-Link DI-604? Of course WinXP & DX9 is a must.....not positive WinXP is but I am sure that DX9 is. My Firmware version is 2.18...the current version. I'll report back w/ my MCM2 findings :)
N8.
N8

Post by N8 »

P.S. That site u posted is neat but it shows an old firmware version. If you select "Tools" then "Misc." in v2.18 you'll find the UPnP option,
N8.
N8

Post by N8 »

See :)

Image
Guest

Post by Guest »

Thanks N8 for checking back. I too have xp with dx9, and the updated router firmware with di-604. I also have both of those settings marked, but still am unable to play any sort of games between the two machines via lan. Im thinking maybe i have something not installed correctly. Im trying to run the games over tcp/ip. Before my router and xp, i had a hub and i used ipx and that seemed to work good, but i read you can use tcp/ip for 98se and xp to play games. Its funny how i can share files and internet, just not games.

Maybe i will just reinstall my 98se os and see if that helps. Im not looking forward to that though.
N8

Post by N8 »

Did some more testing last night. I have 3 PC's on my home network, all 3 have MTM2 & now 2 of them have MCM2(the 3rd has an old video card). The one that can't run MCM2 is also still running Win2k Pro. I accidentally launched MTM2 w/ only DX8.1 & it did not work, of course :)

So I loaded DX9 on that machine just to see if it would work with the other 2 PC's being WinXP & this one being Win2k. To my amazement, it worked fine. Now any of my 3 PC's can host or join any MTM2 game in the zone. MTM2 is DX6-based afaik.

Next was MCM2...mind you, I could only test this on my 2 XP boxes. MCM2 is DX7-based I think & it also worked in all cases with the 2 XP boxes. Either PC could host or join any game that I tried.

No issues to report so far...UPnP operations has been flawless for me w/ DX9...XP or 2k :D
Philmath

Post by Philmath »

I've installed dxports with my netgeaR RP 614 and i've tried to play with 2 pc's in the same room and it was impossible.

So i've installed last firmware for the router, directx 9 and i've configured my pc on win98 SE with no internet gate instead of one (192.168.0.1) before.

I've deleted all the ports forwarded in the router configuration and now all is ok: i can play with the 2 pc's on the same game on gaming zone.
Philmath

Post by Philmath »

I forgot to say that i've put UPNP on, of course!
N8

Post by N8 »

Philmath,

Glad to here you've also had some UPnP success :)
clyde
Posts: 6
Joined: Wed Apr 09, 2003 3:31 pm

Post by clyde »

hi,

a question to all who were able to play with 2 pc AOE over one router in the same game- with directx9 and windows xp.

Did you have the servicepack for xp installed?

clyde
Guest

hey guys

Post by Guest »

Hi guys, i have a Linksys v1.0 router and i would like to have more than one person play TA online through the same router on http://zone.msn.com (http://zone.msn.com/ta/) is the exact link for the gaming lobby and stuff
I want to play with other people online and have people from my lan in the same TA game... is it possible for one person to forward those 2300-2400 and for the other person who's host to just enable the DMZ and host? would that work? no?

my AIM is HarisMyleak
Zone name is Bob_Harley
MSN is Woofer14123@hotmail.com

if any of you would be generous enought contact and help me out? please? i would really really appriciate it!
Woofer14123
Posts: 5
Joined: Sat Nov 29, 2003 1:01 am
Location: Missouri

Post by Woofer14123 »

^^^^^^^^^^ that's me lol
Post Reply